Search moodle.org's
Developer Documentation


  • Bug fixes for general core bugs in 2.8.x ended 9 November 2015 (12 months).
  • Bug fixes for security issues in 2.8.x ended 9 May 2016 (18 months).
  • minimum PHP 5.4.4 (always use latest PHP 5.4.x or 5.5.x on Windows - http://windows.php.net/download/), PHP 7 is NOT supported
  • Differences Between: [Versions 28 and 32] [Versions 28 and 33] [Versions 28 and 34] [Versions 28 and 35]

       1  <?php
       2  // This file is part of Moodle - http://moodle.org/
       3  //
       4  // Moodle is free software: you can redistribute it and/or modify
       5  // it under the terms of the GNU General Public License as published by
       6  // the Free Software Foundation, either version 3 of the License, or
       7  // (at your option) any later version.
       8  //
       9  // Moodle is distributed in the hope that it will be useful,
      10  // but WITHOUT ANY WARRANTY; without even the implied warranty of
      11  // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
      12  // GNU General Public License for more details.
      13  //
      14  // You should have received a copy of the GNU General Public License
      15  // along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
      16  
      17  /**
      18   * Script to show all the assignments that have not been upgraded after the main upgrade.
      19   *
      20   * @package    tool_assignmentupgrade
      21   * @copyright  2012 NetSpot
      22   * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
      23   */
      24  
      25  require_once(dirname(__FILE__) . '/../../../config.php');
      26  require_once($CFG->libdir . '/adminlib.php');
      27  require_once($CFG->dirroot . '/'.$CFG->admin.'/tool/assignmentupgrade/locallib.php');
      28  require_once($CFG->dirroot . '/'.$CFG->admin.'/tool/assignmentupgrade/upgradableassignmentstable.php');
      29  require_once($CFG->dirroot . '/'.$CFG->admin.'/tool/assignmentupgrade/upgradableassignmentsbatchform.php');
      30  require_once($CFG->dirroot . '/'.$CFG->admin.'/tool/assignmentupgrade/paginationform.php');
      31  
      32  // This calls require_login and checks moodle/site:config.
      33  admin_externalpage_setup('assignmentupgrade', '', array(), tool_assignmentupgrade_url('listnotupgraded'));
      34  $PAGE->navbar->add(get_string('listnotupgraded', 'tool_assignmentupgrade'));
      35  
      36  $renderer = $PAGE->get_renderer('tool_assignmentupgrade');
      37  
      38  $perpage = optional_param('perpage', 0, PARAM_INT);
      39  if (!$perpage) {
      40      $perpage = get_user_preferences('tool_assignmentupgrade_perpage', 100);
      41  } else {
      42      set_user_preference('tool_assignmentupgrade_perpage', $perpage);
      43  }
      44  $assignments = new tool_assignmentupgrade_assignments_table($perpage);
      45  
      46  $batchform = new tool_assignmentupgrade_batchoperations_form();
      47  $data = $batchform->get_data();
      48  
      49  if ($data && $data->selectedassignments != '' || $data && isset($data->upgradeall)) {
      50      require_sesskey();
      51      echo $renderer->confirm_batch_operation_page($data);
      52  } else {
      53      $paginationform = new tool_assignmentupgrade_pagination_form();
      54      $pagedata = new stdClass();
      55      $pagedata->perpage = $perpage;
      56      $paginationform->set_data($pagedata);
      57      echo $renderer->assignment_list_page($assignments, $batchform, $paginationform);
      58  }
      59  
    

    Search This Site: