Search moodle.org's
Developer Documentation


  • Bug fixes for general core bugs in 2.8.x ended 9 November 2015 (12 months).
  • Bug fixes for security issues in 2.8.x ended 9 May 2016 (18 months).
  • minimum PHP 5.4.4 (always use latest PHP 5.4.x or 5.5.x on Windows - http://windows.php.net/download/), PHP 7 is NOT supported

  • Class: core_component_testcase  - X-Ref

    Class core_component_testcase.

    test_get_core_subsystems()   X-Ref
    No description

    test_deprecated_get_core_subsystems()   X-Ref
    No description

    test_get_plugin_types()   X-Ref
    No description

    test_deprecated_get_plugin_types()   X-Ref
    No description

    test_get_plugin_list()   X-Ref
    No description

    test_deprecated_get_plugin_list()   X-Ref
    No description

    test_get_plugin_directory()   X-Ref
    No description

    test_deprecated_get_plugin_directory()   X-Ref
    No description

    test_get_subsystem_directory()   X-Ref
    No description

    test_is_valid_plugin_name()   X-Ref
    No description

    test_normalize_componentname()   X-Ref
    No description

    test_normalize_component()   X-Ref
    No description

    test_deprecated_normalize_component()   X-Ref
    No description

    test_get_component_directory()   X-Ref
    No description

    test_deprecated_get_component_directory()   X-Ref
    No description

    test_get_subtype_parent()   X-Ref
    No description

    test_get_subplugins()   X-Ref
    No description

    test_get_plugin_types_with_subplugins()   X-Ref
    No description

    test_get_plugin_list_with_file()   X-Ref
    No description

    Search This Site: