Search moodle.org's
Developer Documentation

  • Bug fixes for general core bugs in 3.10.x will end 8 November 2021 (12 months).
  • Bug fixes for security issues in 3.10.x will end 9 May 2022 (18 months).
  • PHP version: minimum PHP 7.2.0 Note: minimum PHP version has increased since Moodle 3.8. PHP 7.3.x and 7.4.x are supported too.
  • /analytics/ -> lib.php (source)

    The interface library between the core and the subsystem.

    Copyright: 2019 David Mudrák <david@moodle.com>
    License: http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
    File Size: 46 lines (2 kb)
    Included or required:0 times
    Referenced: 0 times
    Includes or requires: 0 files

    Defines 1 function


    Functions that are not part of a class:

    core_analytics_inplace_editable($itemtype, $itemid, $newvalue)   X-Ref
    Implements the inplace editable feature.

    return: \core\output\inplace_editable
    param: string $itemtype Type if the inplace editable element
    param: int $itemid Identifier of the element
    param: string $newvalue New value for the element