Search moodle.org's
Developer Documentation

  • Bug fixes for general core bugs in 3.10.x will end 8 November 2021 (12 months).
  • Bug fixes for security issues in 3.10.x will end 9 May 2022 (18 months).
  • PHP version: minimum PHP 7.2.0 Note: minimum PHP version has increased since Moodle 3.8. PHP 7.3.x and 7.4.x are supported too.
  • Differences Between: [Versions 310 and 34] [Versions 310 and 35] [Versions 34 and 310] [Versions 35 and 310] [Versions 36 and 310] [Versions 37 and 310] [Versions 38 and 310] [Versions 39 and 310]

    Cohort related management functions, this file needs to be included manually.

    Copyright: 2010 Petr Skoda {@link http://skodak.org}
    License: http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
    File Size: 121 lines (5 kb)
    Included or required:0 times
    Referenced: 1 time
    Includes or requires: 0 files

    Defines 1 class

    cohort_edit_form:: (3 methods):
      definition()
      validation()
      get_category_options()


    Class: cohort_edit_form  - X-Ref

    definition()   X-Ref
    Define the cohort edit form


    validation($data, $files)   X-Ref
    No description

    get_category_options($currentcontextid)   X-Ref
    No description