Search moodle.org's
Developer Documentation

  • Bug fixes for general core bugs in 3.11.x will end 14 Nov 2022 (12 months plus 6 months extension).
  • Bug fixes for security issues in 3.11.x will end 13 Nov 2023 (18 months plus 12 months extension).
  • PHP version: minimum PHP 7.3.0 Note: minimum PHP version has increased since Moodle 3.10. PHP 7.4.x is supported too.
  • Differences Between: [Versions 37 and 311] [Versions 38 and 311] [Versions 39 and 311]

       1  <?php
       2  // This file is part of Moodle - https://moodle.org/
       3  //
       4  // Moodle is free software: you can redistribute it and/or modify
       5  // it under the terms of the GNU General Public License as published by
       6  // the Free Software Foundation, either version 3 of the License, or
       7  // (at your option) any later version.
       8  //
       9  // Moodle is distributed in the hope that it will be useful,
      10  // but WITHOUT ANY WARRANTY; without even the implied warranty of
      11  // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
      12  // GNU General Public License for more details.
      13  //
      14  // You should have received a copy of the GNU General Public License
      15  // along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
      16  
      17  /**
      18   * Automatically generated strings for Moodle installer
      19   *
      20   * Do not edit this file manually! It contains just a subset of strings
      21   * needed during the very first steps of installation. This file was
      22   * generated automatically by export-installer.php (which is part of AMOS
      23   * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
      24   * list of strings defined in /install/stringnames.txt.
      25   *
      26   * @package   installer
      27   * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
      28   */
      29  
      30  defined('MOODLE_INTERNAL') || die();
      31  
      32  $string['admindirname'] = 'Directorio Admin';
      33  $string['availablelangs'] = 'Packs d\'idiomas disponibles';
      34  $string['chooselanguagehead'] = 'Triar idioma';
      35  $string['chooselanguagesub'] = 'Per favor, tríe un idioma pa lo proceso d\'instalación. Este idioma s\'usará tamién como idioma per defecto d\'o puesto, si bien puede cambiar-se mas abance.';
      36  $string['clialreadyconfigured'] = 'Lo fichero de configuración config.php ya existe. Per favor, faga servir admin/cli/install_database.php pa instalar Moodle en este puesto.';
      37  $string['clialreadyinstalled'] = 'Lo fichero de configuración config.php ya existe. Per favor, faga servir admin/cli/install_database.php pa actualizar Moodle en este puesto.';
      38  $string['cliinstallheader'] = 'Programa d\'instalación Moodle de linia de comando {$a}';
      39  $string['clitablesexist'] = 'Tablas de base de datos ya existents, la instalación CLI no puede continar.';
      40  $string['databasehost'] = 'Servidor d\'a base de datos';
      41  $string['databasename'] = 'Nombre d\'a base de datos';
      42  $string['databasetypehead'] = 'Tríe lo controlador d\'a base de datos';
      43  $string['dataroot'] = 'Directorio de Datos';
      44  $string['datarootpermission'] = 'Permiso directorios de datos';
      45  $string['dbprefix'] = 'Prefixo de tablas';
      46  $string['dirroot'] = 'Directorio de Moodle';
      47  $string['environmenthead'] = 'Comprebando lo suyo entorno';
      48  $string['environmentsub2'] = 'Cada versión de Moodle tiene bell requisito minimo d\'a versión de PHP y un numero obligatorio d\'extensions de PHP.
      49  Una comprebación de l\'entorno completo se realiza antes de cada instalación y actualización. Per favor, se meta en contacto con l\'administrador d\'o servidor si no sabes cómo instalar la nueva versión u habilitar las extensions PHP.';
      50  $string['errorsinenvironment'] = 'La comprebación de l\'entorno fallo!';
      51  $string['installation'] = 'Instalación';
      52  $string['langdownloaderror'] = 'L\'idioma "{$a}" no podió estar descargau. Lo proceso d\'instalación continará en Anglés.';
      53  $string['memorylimithelp'] = '<p>Lo limite de memoria PHP en o suyo servidor ye actualment {$a}.</p>
      54  
      55  <p>Esto puede ocasionar que Moodle tienga problemas de memoria mas abance, especialment si vusté tiene activaus muitos modulos y/u muitos usuarios.</p>
      56  
      57  <p>Recomendamos que configure PHP con o limite mas alto posible, y.g. 40M.
      58  I hai quantas formas de fer esto:</p>
      59  <ol>
      60  <li>Si puede fer-lo, recompile PHP con <i>--enable-memory-limit</i>.
      61  Esto fa que Moodle fixe per ell mesmo lo limite de memoria.</li>
      62  <li>Si tiene acceso a lo fichero php.ini, puede cambiar l\'achuste <b>memory_limit</b>
      63  a, digamos, 40M. Si no lo tiene, pida a lo suyo administrador que lo faiga per vusté.</li>
      64  <li>En qualques servidors PHP vusté puede creyar en o directorio Moodle un fichero .htaccess que contienga esta linia:
      65  <p><blockquote>php_value memory_limit 40M</blockquote></p>
      66  <p>Manimenos, en qualques servidors esto fa que <b>totas</b> las pachinas PHP deixen de funcionar (podrá veyer las errors quan mire las pachinas) de traza que habrá d\'eliminar lo fichero .htaccess.</p></li>
      67  </ol>';
      68  $string['paths'] = 'Rotas';
      69  $string['pathserrcreatedataroot'] = 'Lo directorio d\'os datos ({$a->dataroot}) no puede estar creyau per l\'instalador.';
      70  $string['pathshead'] = 'Confirme las rotas';
      71  $string['pathsrodataroot'] = 'Lo directorio dataroot no tiene permisos d\'escritura.';
      72  $string['pathsroparentdataroot'] = 'Lo directorio pai ({$a->parent}) no tiene permisos d\'escritura. Lo directorio d\'os datos ({$a->dataroot}) no puede estar creyau per l\'instalador.';
      73  $string['pathssubadmindir'] = 'Muit pocos servidors web usan /admin como un URL especial pa acceder a un panel de control u bella cosa semellant. Lamentablement, esto dentra en conflicto con a ubicación estandard pa las pachinas d\'administración de Moodle. Vusté puede solucionar este problema, renombrando lo directorio admin en a suya instalación Moodle, metendo un nuevo nombre aquí. Per eixemplo: <em> moodleadmin </em>. Esto solucionará los vinclos d\'administración en instalación Moodle.';
      74  $string['pathssubdataroot'] = 'Necesita bell espacio an que Moodle puede alzar los fichers puyaus. En este directorio ha de poder LEYER y ESCRIBIR l\'usuario d\'o servidor web (per lo cheneral \'nobody\',  \'apache\' u \'www-data\'), pero no ha de poder-se acceder a esta carpeta dreitament a traviés d\'a web. L\'instalador tractará de creyar-la si no existe.';
      75  $string['pathssubdirroot'] = '<p>Rota completa d\'o directorio que contiene lo codigo de  Moodle.</p>';
      76  $string['pathssubwwwroot'] = 'Adreza web completa pa acceder a Moodle. No ye posible acceder a Moodle utilizando multiples adrezas. Si lo suyo puesto tiene quantas adrezas publicas ha de configurar redireccions permanents en totas ellas, fueras d\'en2 esta. Si lo suyo puesto web ye accesible tanto dende una intranet como dende Internet, escriba aquí l\'adreza publica y configure la suya DNS pa que los usuarios d\'o suyo intranet puedan tamién utilizar l\'adreza publica.';
      77  $string['pathsunsecuredataroot'] = 'La ubicación de dataroot no ye segura';
      78  $string['pathswrongadmindir'] = 'Lo directorio admin no existe';
      79  $string['phpextension'] = 'Extensión PHP {$a}';
      80  $string['phpversion'] = 'Versión PHP';
      81  $string['phpversionhelp'] = '<p>Moodle requiere a lo menos una versión de PHP 4.3.0 u 5.1.0 ((5.0.x tiene una serie de problemas conoixius).</p>
      82  <p>En este momento ye executando la versión {$a}</p>
      83  <p>Ha d\'actualizar PHP u tresladar-se a unatro servidor con una versión mas recient de PHP!<br />
      84  (En caso de 5.0.x podría tamién revertir a la versión 4.4.x)</p>';
      85  $string['welcomep10'] = '{$a->installername} ({$a->installerversion})';
      86  $string['welcomep20'] = 'Si ye veyendo esta pachina ye perque ha puesto executar lo paquet <strong>{$a->packname} {$a->packversion}</strong> en o suyo ordinador. Parabiens!';
      87  $string['welcomep30'] = 'Esta versión de <strong>{$a->installername}</strong> incluye las
      88      aplicacions necesarias pa que <strong>Moodle</strong> funcione en o suyo ordinador,
      89      principalment:';
      90  $string['welcomep40'] = 'Lo paquet tamién incluye <strong>Moodle {$a->moodlerelease} ({$a->moodleversion})</strong>.';
      91  $string['welcomep50'] = 'L\'uso de totas las aplicacions d\'o paquet ye gubernau per las suyas respectivas
      92      licencias. Lo programa <strong>{$a->installername}</strong> ye
      93      <a href="http://www.opensource.org/docs/definition_plain.html">codigo ubierto</a> y se distribuye
      94      baixo licencia <a href="http://www.gnu.org/copyleft/gpl.html">GPL</a>.';
      95  $string['welcomep60'] = 'Las siguients pachinas le guiarán a traviés de qualques sencillos pasos pa configurar
      96      y achustar <strong>Moodle</strong> en o suyo ordinador. Puede utilizar las valors per defecto sucherius u,
      97      de forma opcional, modificar-los pa que s\'achusten a las suyas necesidatz.';
      98  $string['welcomep70'] = 'Prete en o botón "Siguient" pa continar con a configuración de <strong>Moodle</strong>.';
      99  $string['wwwroot'] = 'Adreza Web';